Beastro - Beastro access is currently down. – Incident details

All systems operational

Beastro access is currently down.

Resolved
Major outage
Started 3 months agoLasted about 3 hours

Affected

Beastro Website

Major outage from 4:25 PM to 7:30 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Microsoft is currently experiencing a global outage affecting Azure and Microsoft 365 services. As a result, access to Beastro and email communication is temporarily unavailable. At this time, there is no estimated resolution timeframe. We are actively monitoring the situation and will provide updates approximately every 30 minutes. We appreciate your patience and understanding. Thank you.

  • Investigating
    Investigating

    We are currently experiencing an outage that is impacting the ability to access Beastro. At this moment, we do not have an estimated timeframe for resolution. We will continue to monitor the situation and will provide updates approximately every 30 minutes. We apologize for any inconvenience this may cause and appreciate your patience and understanding. Thank you.